Aptik 19.12

Aptik v19.12 is now available.

What’s New

Raspberry Pi 4B / ARM Support

Aptik is now available for Debian-based distributions on the ARM platform. This includes Raspberry Pi 3B/3B+/4B, Odroid N2, and other single-board computers running a 32-bit (armhf) or 64-bit(arm64) version of a Debian-based distribution (Raspbian, Armbian, Ubuntu, etc).

A tool like Aptik is less useful on single-board computers, as the SD card can be easily cloned instead of creating an Aptik backup. But it is useful in some situations.

Note:

  • Only the Raspberry Pi 4B and Odroid N2 are officially supported as these are the only SBCs that I have available for testing.
  • Steps for installation are same as for x86 platform. Please refer to the email you received when you purchased the licence.
Aptik running on Raspbian on Raspberry Pi 4

Changelog

  • Flatpak: Fix: Add support for newer Flatpak versions
  • Flatpak: Fix: First package was always ignored when querying installed packages
  • Flatpak: Show column ‘size’ in backup mode
  • Files: Add more warnings to prevent users from adding unnecessary files and folders
  • Files: Prevent users from adding top-level system folders
  • Fix: Error “A process is running in terminal” on Linux Lite 4.6
  • Schedule: Moved the info message to an expander

Purchase

A personal license for Aptik is currently available for $25. This is a single-user license that is valid for lifetime, and includes future updates.

Buy Licence

Install / Update

You will receive an email with installation steps after you purchase a licence.

If you have already purchased the licence, the update will be installed automatically when you update your system. You can install it manually with following commands:

sudo apt update && \
sudo apt install aptik aptik-gtk

3 thoughts on “Aptik 19.12

  1. I only have access to the old free git version, so I don’t know if this is fixed already in your for-pay version: Repo.vala will think that any .list file that ends in a #deb comment is disabled, regardless of its other contents. Fixed by removing the ‘#[ \t]*’ substrings of the regexes in read_lines_debian.

    I’m working on other fixes – drop me a line if interested.

    Like

    1. The paid version handles repos in a different way.
      I’m no longer developing the free version so the fix is not useful for me. Happy coding!

      Like

  2. I am using both Timeshift and Aptik on my computer. I have got the paid Aptik version and using on my Kubuntu distro. Having timeshift on my Arch distro. However i intend to migrate my Arch installation to an other hard drive but sadly realized Aptik does not support anymore Arch? Not even the paid version??

    Like

Leave a Reply to Tony George Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s